E - Help is needed for Dexter
UVA - 11384
Dexter is tired of Dee Dee. So he decided to keep Dee Dee busy in a game. The game he planned for
her is quite easy to play but not easy to win at least not for Dee Dee. But Dexter does not have time
to spend on this silly task, so he wants your help.
There will be a button, when it will be pushed a random number N will be chosen by computer.
Then on screen there will be numbers from 1 to N. Dee Dee can choose any number of numbers from
the numbers on the screen, and then she will command computer to subtract a positive number chosen
by her (not necessarily on screen) from the selected numbers. Her objective will be to make all the
numbers 0.
For example if N = 3, then on screen there will be 3 numbers on screen: 1, 2, 3. Say she now selects
1 and 2. Commands to subtract 1, then the numbers on the screen will be: 0, 1, 3. Then she selects 1
and 3 and commands to subtract 1. Now the numbers are 0, 0, 2. Now she subtracts 2 from 2 and all
the numbers become 0.
Dexter is not so dumb to understand that this can be done very easily, so to make a twist he will
give a limit L for each N and surely L will be as minimum as possible so that it is still possible to win
within L moves. But Dexter does not have time to think how to determine L for each N, so he asks
you to write a code which will take N as input and give L as output.
Input
Input consists of several lines each with N such that 1 ≤ N ≤ 1, 000, 000, 000. Input will be terminated
by end of file.
Output
For each N output L in separate lines.
Sample Input
1
2
3
Sample Output
1
2
2
题意:从1到n的序列,每次选若干个数同时减一个相同的数,使序列最后减为零最少要进行几次操作。
解法:把序列分为两段,后一段进行一次操作后和前一段相等,所以有f(n) = f(n/2) + 1。
代码:
#include<iostream>
using namespace std;
int subtract(int n)
{
return n==1?1:subtract(n/2)+1;
}
int main()
{
int n;
while(cin>>n)
cout<<subtract(n)<<endl;
return 0;
}